What’s Vulnerable › Vulnerabilities
CVE-2018-25058: Twitter-Post-Fetcher Link Target twitterFetcher.js reverse tabnabbing
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-29 · updated 2026-06-17
- Weakness: CWE-1022
Description
A vulnerability classified as problematic has been found in Twitter-Post-Fetcher up to 17.x. This affects an unknown part of the file js/twitterFetcher.js of the component Link Target Handler. The manipulation leads to use of web link to untrusted target with window.opener access. It is possible to initiate the attack remotely. Upgrading to version 18.0.0 is able to address this issue. The name of the patch is 7d281c6fb5acbc29a2cad295262c1f0c19ca56f3. It is recommended to upgrade the affected component. The identifier VDB-217017 was assigned to this vulnerability.
Affected products
- Twitter-Post-Fetcher: before 18.0.0 — fixed in 18.0.0
How to fix
Upgrade to a fixed version: Twitter-Post-Fetcher 18.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/jasonmayes/Twitter-Post-Fetcher/commit/7d281c6fb5acbc29a2cad295262c1f0c19ca56f3
- https://github.com/jasonmayes/Twitter-Post-Fetcher/pull/170
- https://github.com/jasonmayes/Twitter-Post-Fetcher/releases/tag/18.0.0
- https://vuldb.com/?ctiid.217017
- https://vuldb.com/?id.217017
- https://github.com/jasonmayes/Twitter-Post-Fetcher/commit/7d281c6fb5acbc29a2cad295262c1f0c19ca56f3
- https://github.com/jasonmayes/Twitter-Post-Fetcher/pull/170
- https://github.com/jasonmayes/Twitter-Post-Fetcher/releases/tag/18.0.0
- https://vuldb.com/?ctiid.217017
- https://vuldb.com/?id.217017
Get alerted when CVE-2018-25058 or the next vulnerability affects your stack