What’s Vulnerable › Vulnerabilities
CVE-2018-25070: polterguy Phosphorus Five CSV Import NonQuery.cs csv.Read sql injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-07 · updated 2026-06-17
- Weakness: CWE-89
Description
A vulnerability has been found in polterguy Phosphorus Five up to 8.2 and classified as critical. This vulnerability affects the function csv.Read of the file plugins/extras/p5.mysql/NonQuery.cs of the component CSV Import. The manipulation leads to sql injection. Upgrading to version 8.3 is able to address this issue. The patch is identified as c179a3d0703db55cfe0cb939b89593f2e7a87246. It is recommended to upgrade the affected component. VDB-217606 is the identifier assigned to this vulnerability.
Affected products
- polterguy Phosphorus Five: through 8.2
References
- https://github.com/polterguy/phosphorusfive/commit/c179a3d0703db55cfe0cb939b89593f2e7a87246
- https://github.com/polterguy/phosphorusfive/releases/tag/v8.3
- https://vuldb.com/?ctiid.217606
- https://vuldb.com/?id.217606
- https://github.com/polterguy/phosphorusfive/commit/c179a3d0703db55cfe0cb939b89593f2e7a87246
- https://github.com/polterguy/phosphorusfive/releases/tag/v8.3
- https://vuldb.com/?ctiid.217606
- https://vuldb.com/?id.217606
Get alerted when CVE-2018-25070 or the next vulnerability affects your stack