What’s Vulnerable › Vulnerabilities
CVE-2018-25083
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-27 · updated 2026-06-17
- Weakness: CWE-78
Description
The pullit package before 1.4.0 for Node.js allows OS Command Injection because eval is used on an attacker-supplied Git branch name.
Affected products
- Pull It Project Pull It: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: Pull It Project Pull It 1.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/jkup/pullit/commit/4fec455774ee08f4dce0ef2ef934ffcc37219bfb
- https://security.snyk.io/vuln/npm:pullit:20180214
- https://github.com/jkup/pullit/commit/4fec455774ee08f4dce0ef2ef934ffcc37219bfb
- https://security.snyk.io/vuln/npm:pullit:20180214
Get alerted when CVE-2018-25083 or the next vulnerability affects your stack