What’s Vulnerable › Vulnerabilities
CVE-2018-25085: Responsive Menus Configuration Setting responsive_menus.module responsive_menus_admin_form_submit cross site scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-01 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability classified as problematic was found in Responsive Menus 7.x-1.x-dev on Drupal. Affected by this vulnerability is the function responsive_menus_admin_form_submit of the file responsive_menus.module of the component Configuration Setting Handler. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 7.x-1.7 is able to address this issue. The patch is named 3c554b31d32a367188f44d44857b061eac949fb8. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-227755.
Affected products
- Responsive Menus: before 7.x-1.7 — fixed in 7.x-1.7
How to fix
Upgrade to a fixed version: Responsive Menus 7.x-1.7. Check the vendor advisory for mitigations.
References
- https://git.drupalcode.org/project/responsive_menus/-/commit/3c554b31d32a367188f44d44857b061eac949fb8
- https://vuldb.com/?ctiid.227755
- https://vuldb.com/?id.227755
- https://www.drupal.org/project/responsive_menus/releases/7.x-1.7
- https://www.drupal.org/sa-contrib-2018-079
- https://git.drupalcode.org/project/responsive_menus/-/commit/3c554b31d32a367188f44d44857b061eac949fb8
- https://vuldb.com/?ctiid.227755
- https://vuldb.com/?id.227755
- https://www.drupal.org/project/responsive_menus/releases/7.x-1.7
- https://www.drupal.org/sa-contrib-2018-079
Get alerted when CVE-2018-25085 or the next vulnerability affects your stack