What’s Vulnerable › Vulnerabilities
CVE-2018-25088: Blue Yonder postgraas_server PostgreSQL Backend postgres_cluster_driver.py create_postgres_db sql injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-18 · updated 2026-06-17
- Weakness: CWE-89
Description
A vulnerability, which was classified as critical, was found in Blue Yonder postgraas_server up to 2.0.0b2. Affected is the function _create_pg_connection/create_postgres_db of the file postgraas_server/backends/postgres_cluster/postgres_cluster_driver.py of the component PostgreSQL Backend Handler. The manipulation leads to sql injection. Upgrading to version 2.0.0 is able to address this issue. The patch is identified as 7cd8d016edc74a78af0d81c948bfafbcc93c937c. It is recommended to upgrade the affected component. VDB-234246 is the identifier assigned to this vulnerability.
Affected products
- Blue Yonder postgraas_server: before 2.0.0; 2.0.0-beta1, 2.0.0-beta2 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Blue Yonder postgraas_server 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/blue-yonder/postgraas_server/commit/7cd8d016edc74a78af0d81c948bfafbcc93c937c
- https://github.com/blue-yonder/postgraas_server/releases/tag/v2.0.0
- https://vuldb.com/?ctiid.234246
- https://vuldb.com/?id.234246
- https://github.com/blue-yonder/postgraas_server/commit/7cd8d016edc74a78af0d81c948bfafbcc93c937c
- https://github.com/blue-yonder/postgraas_server/releases/tag/v2.0.0
- https://vuldb.com/?ctiid.234246
- https://vuldb.com/?id.234246
Get alerted when CVE-2018-25088 or the next vulnerability affects your stack