What’s Vulnerable › Vulnerabilities
CVE-2018-25099
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-18 · updated 2026-06-17
- Weakness: CWE-347
Description
In the CryptX module before 0.062 for Perl, gcm_decrypt_verify() and chacha20poly1305_decrypt_verify() do not verify the tag.
Affected products
- Dcit Perl-Cryptx: before 0.062 — fixed in 0.062
How to fix
Upgrade to a fixed version: Dcit Perl-Cryptx 0.062. Check the vendor advisory for mitigations.
References
- https://github.com/DCIT/perl-CryptX/issues/47
- https://github.com/libtom/libtomcrypt/pull/451
- https://metacpan.org/dist/CryptX/changes
- https://github.com/DCIT/perl-CryptX/issues/47
- https://github.com/libtom/libtomcrypt/pull/451
- https://metacpan.org/dist/CryptX/changes
Get alerted when CVE-2018-25099 or the next vulnerability affects your stack