What’s Vulnerable › Vulnerabilities
CVE-2018-25104: CoinGate Plugin Payment callback.php postProcess logic error
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-17 · updated 2026-06-17
- Weakness: CWE-840
Description
A vulnerability was found in CoinGate Plugin up to 1.2.7 on PrestaShop. It has been rated as problematic. Affected by this issue is the function postProcess of the file modules/coingate/controllers/front/callback.php of the component Payment Handler. The manipulation leads to business logic errors. The attack may be launched remotely. Upgrading to version 1.2.8 is able to address this issue. The patch is identified as 0a3097db0aec7c5d66686c142c6abaa1e126ca16. It is recommended to upgrade the affected component.
Affected products
- CoinGate Plugin: 1.2.0, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.5 (+2)
References
- https://github.com/coingate/prestashop-plugin/commit/0a3097db0aec7c5d66686c142c6abaa1e126ca16
- https://github.com/coingate/prestashop-plugin/releases/tag/v1.2.8
- https://vuldb.com/?ctiid.280358
- https://vuldb.com/?id.280358
Get alerted when CVE-2018-25104 or the next vulnerability affects your stack