What’s Vulnerable › Vulnerabilities
CVE-2018-25119: Nagios Fusion < 4.1.5 XSS via fusionwindow Parameter
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-30 · updated 2026-10-18
- Weakness: CWE-79
Description
Nagios Fusion versions prior to 4.1.5 are vulnerable to cross-site scripting (XSS) via the "fusionwindow" parameter. Insufficient validation or escaping of user-supplied input may allow an attacker to inject and execute arbitrary script in the context of a victim's browser.
Affected products
- Nagios Fusion: before 4.1.5 — fixed in 4.1.5
How to fix
Upgrade to a fixed version: Nagios Fusion 4.1.5. Check the vendor advisory for mitigations.
References
- https://www.nagios.com/changelog/nagios-fusion/
- https://www.vulncheck.com/advisories/nagios-fusion-xss-via-fusionwindow-parameter
Get alerted when CVE-2018-25119 or the next vulnerability affects your stack