What’s Vulnerable › Vulnerabilities
CVE-2018-25438: Intermesh Group-Office < 3.5.5 Path Traversal via compress.php
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-28
- Weakness: CWE-22
Description
Intermesh Group-Office 3.3.0 before 3.5.5 contains an unauthenticated path traversal vulnerability in compress.php that allows remote attackers to read arbitrary files by manipulating the 'file' parameter. Attackers can send GET requests to /compress.php with '../' sequences in the 'file' parameter, which is appended to the cache path and passed to readfile(), to read files such as /etc/passwd. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-21.
Affected products
- Intermesh Group-Office: from 3.3.0 before 3.5.5 — fixed in 3.5.5
How to fix
Upgrade to a fixed version: Intermesh Group-Office 3.5.5. Check the vendor advisory for mitigations.
References
- https://cxsecurity.com/issue/WLB-2018020249
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/vulnerabilities/other/groupoffice-lfi.yaml
- https://www.group-office.com/
- https://www.vulncheck.com/advisories/intermesh-group-office-3.5.5-path-traversal-via-compress-php
Get alerted when CVE-2018-25438 or the next vulnerability affects your stack