What’s Vulnerable › Vulnerabilities
CVE-2018-2677
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-18 · updated 2026-06-17
Description
Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: AWT). Supported versions that are affected are Java SE: 6u171, 7u161, 8u152 and 9.0.1; Java SE Embedded: 8u151. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Java SE, Java SE Embedded. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments, typically in servers, that load and run only trusted code (e.g., code installed by an administrator). CVSS 3.0 Base Score 4.3 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L).
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- Debian Linux: 7.0, 8.0, 9.0
- HP Xp7 Command View: from 8.6.2-01
- Hewlett Packard Enterprise HPE Command View Advanced Edition: from 8.6.2-01
- HP Xp P9000 Command View: from 8.6.2-01
- Oracle Java SE: 1.6.0-update171, 1.7.0-update161, 1.8.0-update152, 9.0.1
- Oracle Java SE: 1.6.0-update171, 1.7.0-update161, 1.8.0-update152, 9.0.1
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.4, 7.6
- RedHat Enterprise Linux Server Eus: 7.4, 7.5, 7.6
- RedHat Enterprise Linux Server Tus: 7.4, 7.6
- RedHat Enterprise Linux Workstation: 6.0, 7.0
- Red Hat Satellite 6: 5.6, 5.7, 5.8
- Schneider Electric StruxureWare Data Center Expert: before 7.6.0 — fixed in 7.6.0
How to fix
Upgrade to a fixed version: Schneider Electric StruxureWare Data Center Expert 7.6.0. Check the vendor advisory for mitigations.
References
- http://www.oracle.com/technetwork/security-advisory/cpujan2018-3236628.html
- http://www.securityfocus.com/bid/102656
- http://www.securitytracker.com/id/1040203
- https://access.redhat.com/errata/RHSA-2018:0095
- https://access.redhat.com/errata/RHSA-2018:0099
- https://access.redhat.com/errata/RHSA-2018:0100
- https://access.redhat.com/errata/RHSA-2018:0115
- https://access.redhat.com/errata/RHSA-2018:0349
- https://access.redhat.com/errata/RHSA-2018:0351
- https://access.redhat.com/errata/RHSA-2018:0352
- https://access.redhat.com/errata/RHSA-2018:0458
- https://access.redhat.com/errata/RHSA-2018:0521
Get alerted when CVE-2018-2677 or the next vulnerability affects your stack