What’s Vulnerable › Vulnerabilities

CVE-2018-2771

Description

Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Locking). Supported versions that are affected are 5.5.59 and prior, 5.6.39 and prior and 5.7.21 and prior. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.0 Base Score 4.4 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H).

Affected products

How to fix

Upgrade to a fixed version: MariaDB 10.0.35, 10.1.33, 10.2.15, 5.5.60. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-2771 or the next vulnerability affects your stack