What’s Vulnerable › Vulnerabilities
CVE-2018-2813
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-19 · updated 2026-06-17
Description
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: DDL). Supported versions that are affected are 5.5.59 and prior, 5.6.39 and prior and 5.7.21 and prior. Easily exploitable vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized read access to a subset of MySQL Server accessible data. CVSS 3.0 Base Score 4.3 (Confidentiality impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N).
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 17.10, 18.04
- Debian Linux: 7.0, 8.0, 9.0
- MariaDB: from 5.5.0 before 5.5.60; from 10.0.0 before 10.0.35; from 10.1.0 before 10.1.33; from 10.2.0 before 10.2.15 — fixed in 10.0.35, 10.1.33, 10.2.15, 5.5.60
- OnCommand Insight: all versions
- NetApp OnCommand Unified Manager for 7-Mode (core package): from 7.3; from 9.4
- NetApp OnCommand Workflow Automation: all versions
- NetApp SnapCenter: all versions
- NetApp Storage Automation Store: all versions
- MySQL Server: from 5.5.0 through 5.5.59; from 5.6.0 through 5.6.39; from 5.7.0 through 5.7.21
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.5, 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
- OpenStack: 12
How to fix
Upgrade to a fixed version: MariaDB 10.0.35, 10.1.33, 10.2.15, 5.5.60. Check the vendor advisory for mitigations.
References
- http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html
- http://www.securityfocus.com/bid/103830
- http://www.securitytracker.com/id/1040698
- https://access.redhat.com/errata/RHSA-2018:1254
- https://access.redhat.com/errata/RHSA-2018:2439
- https://access.redhat.com/errata/RHSA-2018:2729
- https://access.redhat.com/errata/RHSA-2018:3655
- https://access.redhat.com/errata/RHSA-2019:1258
- https://lists.debian.org/debian-lts-announce/2018/04/msg00020.html
- https://lists.debian.org/debian-lts-announce/2018/06/msg00015.html
- https://security.gentoo.org/glsa/201908-24
- https://security.netapp.com/advisory/ntap-20180419-0002/
Get alerted when CVE-2018-2813 or the next vulnerability affects your stack