What’s Vulnerable › Vulnerabilities
CVE-2018-3712
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-06-07 · updated 2026-06-17
- Weakness: CWE-22
Description
serve node module before 6.4.9 suffers from a Path Traversal vulnerability due to not handling %2e (.) and %2f (/) and allowing them in paths, which allows a malicious user to view the contents of any directory with known path.
Affected products
- serve: before 6.4.9 — fixed in 6.4.9
How to fix
Upgrade to a fixed version: serve 6.4.9. Check the vendor advisory for mitigations.
References
- https://github.com/zeit/serve/pull/316
- https://hackerone.com/reports/307666
- https://github.com/zeit/serve/pull/316
- https://hackerone.com/reports/307666
Get alerted when CVE-2018-3712 or the next vulnerability affects your stack