What’s Vulnerable › Vulnerabilities
CVE-2018-3715
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-06-07 · updated 2026-06-17
- Weakness: CWE-22
Description
glance node module before 3.0.4 suffers from a Path Traversal vulnerability due to lack of validation of path passed to it, which allows a malicious user to read content of any file with known path.
Affected products
- glance: before 3.0.4 — fixed in 3.0.4
How to fix
Upgrade to a fixed version: glance 3.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/jarofghosts/glance/commit/8cfd88e44ebd3f07e3a2eaf376a3e758b6c4ca19
- https://hackerone.com/reports/310106
- https://github.com/jarofghosts/glance/commit/8cfd88e44ebd3f07e3a2eaf376a3e758b6c4ca19
- https://hackerone.com/reports/310106
Get alerted when CVE-2018-3715 or the next vulnerability affects your stack