What’s Vulnerable › Vulnerabilities
CVE-2018-3717
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-06-07 · updated 2026-06-17
- Weakness: CWE-79
Description
connect node module before 2.14.0 suffers from a Cross-Site Scripting (XSS) vulnerability due to a lack of validation of file in directory.js middleware.
Affected products
- HackerOne connect node module: before 2.14.0 — fixed in 2.14.0
How to fix
Upgrade to a fixed version: HackerOne connect node module 2.14.0. Check the vendor advisory for mitigations.
References
- https://github.com/senchalabs/connect/commit/6d5dd30075d2bc4ee97afdbbe3d9d98d8d52d74b
- https://hackerone.com/reports/309394
- https://hackerone.com/reports/309641
- https://github.com/senchalabs/connect/commit/6d5dd30075d2bc4ee97afdbbe3d9d98d8d52d74b
- https://hackerone.com/reports/309394
- https://hackerone.com/reports/309641
Get alerted when CVE-2018-3717 or the next vulnerability affects your stack