What’s Vulnerable › Vulnerabilities
CVE-2018-3722
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-06-07 · updated 2026-06-17
- Weakness: CWE-471
Description
merge-deep node module before 3.0.1 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability, which allows a malicious user to modify the prototype of "Object" via __proto__, causing the addition or modification of an existing property that will exist on all objects.
Affected products
- HackerOne merge-deep node module: before 3.0.1 — fixed in 3.0.1
How to fix
Upgrade to a fixed version: HackerOne merge-deep node module 3.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/jonschlinkert/merge-deep/commit/2c33634da7129a5aefcc262d2fec2e72224404e5
- https://hackerone.com/reports/310708
- https://github.com/jonschlinkert/merge-deep/commit/2c33634da7129a5aefcc262d2fec2e72224404e5
- https://hackerone.com/reports/310708
Get alerted when CVE-2018-3722 or the next vulnerability affects your stack