What’s Vulnerable › Vulnerabilities
CVE-2018-3732
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-06-07 · updated 2026-06-17
- Weakness: CWE-22
Description
resolve-path node module before 1.4.0 suffers from a Path Traversal vulnerability due to lack of validation of paths with certain special characters, which allows a malicious user to read content of any file with known path.
Affected products
- HackerOne resolve-path node module: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: HackerOne resolve-path node module 1.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/pillarjs/resolve-path/commit/fe5b8052cafd35fcdafe9210e100e9050b37d2a0
- https://hackerone.com/reports/315760
- https://github.com/pillarjs/resolve-path/commit/fe5b8052cafd35fcdafe9210e100e9050b37d2a0
- https://hackerone.com/reports/315760
Get alerted when CVE-2018-3732 or the next vulnerability affects your stack