What’s Vulnerable › Vulnerabilities
CVE-2018-3739
- Severity: critical (CVSS 9.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-06-07 · updated 2026-06-17
- Weakness: CWE-400
Description
https-proxy-agent before 2.1.1 passes auth option to the Buffer constructor without proper sanitization, resulting in DoS and uninitialized memory leak in setups where an attacker could submit typed input to the 'auth' parameter (e.g. JSON).
Affected products
- HackerOne https-proxy-agent node module: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: HackerOne https-proxy-agent node module 2.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-3739 or the next vulnerability affects your stack