What’s Vulnerable › Vulnerabilities
CVE-2018-3761
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-05 · updated 2026-06-17
- Weakness: CWE-287
Description
Nextcloud Server before 12.0.8 and 13.0.3 suffer from improper authentication on the OAuth2 token endpoint. Missing checks potentially allowed handing out new tokens in case the OAuth2 client was partly compromised.
Affected products
- Nextcloud Server: before 12.0.8; from 13.0.0 before 13.0.3 — fixed in 12.0.8, 13.0.3
How to fix
Upgrade to a fixed version: Nextcloud Server 12.0.8, 13.0.3. Check the vendor advisory for mitigations.
References
- https://hackerone.com/reports/343111
- https://nextcloud.com/security/advisory/?id=nc-sa-2018-003
- https://hackerone.com/reports/343111
- https://nextcloud.com/security/advisory/?id=nc-sa-2018-003
Get alerted when CVE-2018-3761 or the next vulnerability affects your stack