What’s Vulnerable › Vulnerabilities
CVE-2018-3772
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-07-30 · updated 2026-06-17
- Weakness: CWE-77
Description
Concatenating unsanitized user input in the `whereis` npm module < 0.4.1 allowed an attacker to execute arbitrary commands. The `whereis` module is deprecated and it is recommended to use the `which` npm module instead.
Affected products
- https://github.com/vvo whereis: before 0.4.1 — fixed in 0.4.1
How to fix
Upgrade to a fixed version: https://github.com/vvo whereis 0.4.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-3772 or the next vulnerability affects your stack