What’s Vulnerable › Vulnerabilities
CVE-2018-3777
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-03 · updated 2026-06-17
- Weakness: CWE-20
Description
Insufficient URI encoding in restforce before 3.0.0 allows attacker to inject arbitrary parameters into Salesforce API requests.
Affected products
- https://github.com/restforce restforce ruby gem: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: https://github.com/restforce restforce ruby gem 3.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-3777 or the next vulnerability affects your stack