What’s Vulnerable › Vulnerabilities
CVE-2018-3778
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-08 · updated 2026-06-17
- Weakness: CWE-285
Description
Improper authorization in aedes version <0.35.0 will publish a LWT in a channel when a client is not authorized.
Affected products
- HackerOne aedes: before 0.35.0 — fixed in 0.35.0
How to fix
Upgrade to a fixed version: HackerOne aedes 0.35.0. Check the vendor advisory for mitigations.
References
- https://github.com/mcollina/aedes/issues/211
- https://github.com/mcollina/aedes/issues/212
- https://github.com/nodejs/security-wg/blob/master/vuln/npm/457.json
- https://github.com/mcollina/aedes/issues/211
- https://github.com/mcollina/aedes/issues/212
- https://github.com/nodejs/security-wg/blob/master/vuln/npm/457.json
Get alerted when CVE-2018-3778 or the next vulnerability affects your stack