What’s Vulnerable › Vulnerabilities
CVE-2018-3786
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-08-24 · updated 2026-06-17
- Weakness: CWE-77
Description
A command injection vulnerability in egg-scripts <v2.8.1 allows arbitrary shell command execution through a maliciously crafted command line argument.
Affected products
- egg-scripts: before 2.8.1 — fixed in 2.8.1
How to fix
Upgrade to a fixed version: egg-scripts 2.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/eggjs/egg-scripts/blob/2.8.1/History.md
- https://github.com/eggjs/egg-scripts/pull/26
- https://hackerone.com/reports/388936
- https://github.com/eggjs/egg-scripts/blob/2.8.1/History.md
- https://github.com/eggjs/egg-scripts/pull/26
- https://hackerone.com/reports/388936
Get alerted when CVE-2018-3786 or the next vulnerability affects your stack