What’s Vulnerable › Vulnerabilities
CVE-2018-3810
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 91.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-01-01 · updated 2026-06-17
- Weakness: CWE-287
Description
Authentication Bypass vulnerability in the Oturia Smart Google Code Inserter plugin before 3.5 for WordPress allows unauthenticated attackers to insert arbitrary JavaScript or HTML code (via the sgcgoogleanalytic parameter) that runs on all pages served by WordPress. The saveGoogleCode() function in smartgooglecode.php does not check if the current request is made by an authorized user, thus allowing any unauthenticated user to successfully update the inserted code.
Affected products
- Oturia Smart Google Code Inserter: before 3.5 — fixed in 3.5
How to fix
Upgrade to a fixed version: Oturia Smart Google Code Inserter 3.5. Check the vendor advisory for mitigations.
References
- https://limbenjamin.com/articles/smart-google-code-inserter-auth-bypass.html
- https://wordpress.org/plugins/smart-google-code-inserter/#developers
- https://wpvulndb.com/vulnerabilities/8987
- https://www.exploit-db.com/exploits/43420/
- https://limbenjamin.com/articles/smart-google-code-inserter-auth-bypass.html
- https://wordpress.org/plugins/smart-google-code-inserter/#developers
- https://wpvulndb.com/vulnerabilities/8987
- https://www.exploit-db.com/exploits/43420/
Get alerted when CVE-2018-3810 or the next vulnerability affects your stack