What’s Vulnerable › Vulnerabilities
CVE-2018-3811
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 42.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-01-01 · updated 2026-06-17
- Weakness: CWE-89
Description
SQL Injection vulnerability in the Oturia Smart Google Code Inserter plugin before 3.5 for WordPress allows unauthenticated attackers to execute SQL queries in the context of the web server. The saveGoogleAdWords() function in smartgooglecode.php did not use prepared statements and did not sanitize the $_POST["oId"] variable before passing it as input into the SQL query.
Affected products
- Oturia Smart Google Code Inserter: before 3.5 — fixed in 3.5
How to fix
Upgrade to a fixed version: Oturia Smart Google Code Inserter 3.5. Check the vendor advisory for mitigations.
References
- https://limbenjamin.com/articles/smart-google-code-inserter-auth-bypass.html
- https://wordpress.org/plugins/smart-google-code-inserter/#developers
- https://wpvulndb.com/vulnerabilities/8988
- https://www.exploit-db.com/exploits/43420/
- https://limbenjamin.com/articles/smart-google-code-inserter-auth-bypass.html
- https://wordpress.org/plugins/smart-google-code-inserter/#developers
- https://wpvulndb.com/vulnerabilities/8988
- https://www.exploit-db.com/exploits/43420/
Get alerted when CVE-2018-3811 or the next vulnerability affects your stack