What’s Vulnerable › Vulnerabilities
CVE-2018-3817
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-30 · updated 2026-06-17
- Weakness: CWE-532
Description
When logging warnings regarding deprecated settings, Logstash before 5.6.6 and 6.x before 6.1.2 could inadvertently log sensitive information.
Affected products
- Elastic Logstash: before 5.6.6; from 6.0.0 before 6.1.2 — fixed in 5.6.6, 6.1.2
How to fix
Upgrade to a fixed version: Elastic Logstash 5.6.6, 6.1.2. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/elastic-stack-6-1-2-and-5-6-6-security-update/115763
- https://discuss.elastic.co/t/elastic-stack-6-1-2-and-5-6-6-security-update/115763
Get alerted when CVE-2018-3817 or the next vulnerability affects your stack