What’s Vulnerable › Vulnerabilities
CVE-2018-3824
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-19 · updated 2026-06-17
- Weakness: CWE-79
Description
X-Pack Machine Learning versions before 6.2.4 and 5.6.9 had a cross-site scripting (XSS) vulnerability. If an attacker is able to inject data into an index that has a ML job running against it, then when another user views the results of the ML job it could allow the attacker to obtain sensitive information from or perform destructive actions on behalf of that other ML user.
Affected products
- Elasticsearch X-Pack: before 5.6.9; from 6.0.0 before 6.2.4 — fixed in 5.6.9, 6.2.4
- Elastic Kibana X-Pack: before 5.6.9; from 6.0.0 before 6.2.4 — fixed in 5.6.9, 6.2.4
- Elastic Logstash X-Pack: before 5.6.9; from 6.1.0 before 6.2.4 — fixed in 5.6.9, 6.2.4
How to fix
Upgrade to a fixed version: Elasticsearch X-Pack 5.6.9, 6.2.4; Elastic Kibana X-Pack 5.6.9, 6.2.4; Elastic Logstash X-Pack 5.6.9, 6.2.4. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/elastic-stack-6-2-4-and-5-6-9-security-update/128422
- https://www.elastic.co/community/security
- https://discuss.elastic.co/t/elastic-stack-6-2-4-and-5-6-9-security-update/128422
- https://www.elastic.co/community/security
Get alerted when CVE-2018-3824 or the next vulnerability affects your stack