What’s Vulnerable › Vulnerabilities
CVE-2018-4139
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-04-03 · updated 2026-06-17
- Weakness: CWE-119
Description
An issue was discovered in certain Apple products. macOS before 10.13.4 is affected. The issue involves the "kext tools" component. It allows attackers to execute arbitrary code in a privileged context or cause a denial of service (memory corruption) via a crafted app.
Affected products
- macOS: before 10.13.4 — fixed in 10.13.4
How to fix
Upgrade to a fixed version: macOS 10.13.4. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103582
- http://www.securitytracker.com/id/1040608
- https://support.apple.com/HT208692
- https://www.exploit-db.com/exploits/44561/
- http://www.securityfocus.com/bid/103582
- http://www.securitytracker.com/id/1040608
- https://support.apple.com/HT208692
- https://www.exploit-db.com/exploits/44561/
Get alerted when CVE-2018-4139 or the next vulnerability affects your stack