What’s Vulnerable › Vulnerabilities
CVE-2018-4164
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-03 · updated 2026-06-17
Description
An issue was discovered in certain Apple products. Xcode before 9.3 is affected. The issue, which is unspecified, involves the "LLVM" component.
Affected products
- Apple Xcode: before 9.3 — fixed in 9.3
How to fix
Upgrade to a fixed version: Apple Xcode 9.3. Check the vendor advisory for mitigations.
References
- http://lists.llvm.org/pipermail/llvm-commits/
- http://releases.llvm.org/
- http://www.securityfocus.com/bid/103583
- http://www.securitytracker.com/id/1040610
- https://developer.apple.com/library/content/releasenotes/DeveloperTools/RN-Xcode/Chapters/Introduction.html
- https://support.apple.com/HT208699
- http://lists.llvm.org/pipermail/llvm-commits/
- http://releases.llvm.org/
- http://www.securityfocus.com/bid/103583
- http://www.securitytracker.com/id/1040610
- https://developer.apple.com/library/content/releasenotes/DeveloperTools/RN-Xcode/Chapters/Introduction.html
- https://support.apple.com/HT208699
Get alerted when CVE-2018-4164 or the next vulnerability affects your stack