What’s Vulnerable › Vulnerabilities
CVE-2018-4178
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-03 · updated 2026-06-17
- Weakness: CWE-732
Description
A permissions issue existed in which execute permission was incorrectly granted. This issue was addressed with improved permission validation. This issue affected versions prior to macOS High Sierra 10.13.4.
Affected products
- macOS: before 10.13.4 — fixed in 10.13.4
How to fix
Upgrade to a fixed version: macOS 10.13.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-4178 or the next vulnerability affects your stack