What’s Vulnerable › Vulnerabilities
CVE-2018-4210
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-11 · updated 2026-06-17
- Weakness: CWE-129
Description
In iOS before 11.3, Safari before 11.1, tvOS before 11.3, watchOS before 4.3, iTunes before 12.7.4 for Windows, an array indexing issue existed in the handling of a function in javascript core. This issue was addressed with improved checks.
Affected products
- Apple Iphone Os: before 11.3 — fixed in 11.3
- Apple iTunes for Windows: before 12.7.4 — fixed in 12.7.4
- Apple Safari: before 11.1 — fixed in 11.1
- Apple tvOS: before 11.3 — fixed in 11.3
- Apple watchOS: before 4.3 — fixed in 4.3
- Canonical Ubuntu Linux: 18.04
- Webkitgtk+: before 2.22.0 — fixed in 2.22.0
How to fix
Upgrade to a fixed version: Apple Iphone Os 11.3; Apple iTunes for Windows 12.7.4; Apple Safari 11.1; Apple tvOS 11.3; Apple watchOS 4.3; Webkitgtk+ 2.22.0. Check the vendor advisory for mitigations.
References
- https://security.gentoo.org/glsa/201812-04
- https://support.apple.com/HT208693%2C
- https://support.apple.com/HT208694%2C
- https://support.apple.com/HT208695%2C
- https://support.apple.com/HT208698
- https://usn.ubuntu.com/3781-1/
- https://security.gentoo.org/glsa/201812-04
- https://support.apple.com/HT208693%2C
- https://support.apple.com/HT208694%2C
- https://support.apple.com/HT208695%2C
- https://support.apple.com/HT208698
- https://usn.ubuntu.com/3781-1/
Get alerted when CVE-2018-4210 or the next vulnerability affects your stack