What’s Vulnerable › Vulnerabilities
CVE-2018-4220
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-08 · updated 2026-06-17
- Weakness: CWE-732
Description
An issue was discovered in certain Apple products. Swift before 4.1.1 Security Update 2018-001 is affected. The issue involves the "Swift for Ubuntu" component. It allows attackers to execute arbitrary code in a privileged context because write and execute permissions are enabled during library loading.
Affected products
- Swift Project Swift Corelib-Foundation: before 4.1.1 — fixed in 4.1.1
How to fix
Upgrade to a fixed version: Swift Project Swift Corelib-Foundation 4.1.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104085
- https://support.apple.com/HT208804
- http://www.securityfocus.com/bid/104085
- https://support.apple.com/HT208804
Get alerted when CVE-2018-4220 or the next vulnerability affects your stack