What’s Vulnerable › Vulnerabilities
CVE-2018-4258
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-11 · updated 2026-06-17
- Weakness: CWE-119
Description
In macOS High Sierra before 10.13.5, a buffer overflow was addressed with improved bounds checking.
Affected products
- macOS: before 10.13.5 — fixed in 10.13.5
How to fix
Upgrade to a fixed version: macOS 10.13.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-4258 or the next vulnerability affects your stack