What’s Vulnerable › Vulnerabilities
CVE-2018-4300
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-03 · updated 2026-06-17
- Weakness: CWE-200
Description
The session cookie generated by the CUPS web interface was easy to guess on Linux, allowing unauthorized scripted access to the web interface when the web interface is enabled. This issue affected versions prior to v2.2.10.
Affected products
- cups: before 2.2.10 — fixed in 2.2.10
How to fix
Upgrade to a fixed version: cups 2.2.10. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107785
- https://github.com/apple/cups/releases/tag/v2.2.10
- https://lists.debian.org/debian-lts-announce/2019/09/msg00028.html
- http://www.securityfocus.com/bid/107785
- https://github.com/apple/cups/releases/tag/v2.2.10
- https://lists.debian.org/debian-lts-announce/2019/09/msg00028.html
Get alerted when CVE-2018-4300 or the next vulnerability affects your stack