What’s Vulnerable › Vulnerabilities
CVE-2018-4950
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-09 · updated 2026-06-17
- Weakness: CWE-787
Description
Adobe Acrobat and Reader versions 2018.011.20038 and earlier, 2017.011.30079 and earlier, and 2015.006.30417 and earlier have an Out-of-bounds write vulnerability. Successful exploitation could lead to arbitrary code execution in the context of the current user.
Affected products
- Adobe Acrobat DC: from 15.006.30417 before 15.006.30418; from 17.011.30079 before 17.011.30080; from 18.011.20038 before 18.011.20040 — fixed in 15.006.30418, 17.011.30080, 18.011.20040
- Adobe Acrobat Reader: from 15.006.30417 before 15.006.30418; from 17.011.30079 before 17.011.30080; from 18.011.20038 before 18.011.20040 — fixed in 15.006.30418, 17.011.30080, 18.011.20040
How to fix
Upgrade to a fixed version: Adobe Acrobat DC 15.006.30418, 17.011.30080, 18.011.20040; Adobe Acrobat Reader 15.006.30418, 17.011.30080, 18.011.20040. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104174
- http://www.securitytracker.com/id/1040920
- https://helpx.adobe.com/security/products/acrobat/apsb18-09.html
- http://www.securityfocus.com/bid/104174
- http://www.securitytracker.com/id/1040920
- https://helpx.adobe.com/security/products/acrobat/apsb18-09.html
Get alerted when CVE-2018-4950 or the next vulnerability affects your stack