What’s Vulnerable › Vulnerabilities
CVE-2018-5102
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-11 · updated 2026-06-17
- Weakness: CWE-416
Description
A use-after-free vulnerability can occur when manipulating HTML media elements with media streams, resulting in a potentially exploitable crash. This vulnerability affects Thunderbird < 52.6, Firefox ESR < 52.6, and Firefox < 58.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- Debian Linux: 7.0, 8.0, 9.0
- Mozilla Firefox: before 58.0; before 52.6.0 — fixed in 52.6.0, 58.0
- Mozilla Thunderbird: before 52.6.0 — fixed in 52.6.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.4
- RedHat Enterprise Linux Server Eus: 7.4, 7.5
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 52.6.0, 58.0; Mozilla Thunderbird 52.6.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/102783
- http://www.securitytracker.com/id/1040270
- https://access.redhat.com/errata/RHSA-2018:0122
- https://access.redhat.com/errata/RHSA-2018:0262
- https://bugzilla.mozilla.org/show_bug.cgi?id=1419363
- https://lists.debian.org/debian-lts-announce/2018/01/msg00030.html
- https://lists.debian.org/debian-lts-announce/2018/01/msg00036.html
- https://usn.ubuntu.com/3544-1/
- https://www.debian.org/security/2018/dsa-4096
- https://www.debian.org/security/2018/dsa-4102
- https://www.mozilla.org/security/advisories/mfsa2018-02/
- https://www.mozilla.org/security/advisories/mfsa2018-03/
Get alerted when CVE-2018-5102 or the next vulnerability affects your stack