What’s Vulnerable › Vulnerabilities
CVE-2018-5129
- Severity: high (CVSS 8.6 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-11 · updated 2026-06-17
- Weakness: CWE-787
Description
A lack of parameter validation on IPC messages results in a potential out-of-bounds write through malformed IPC messages. This can potentially allow for sandbox escape through memory corruption in the parent process. This vulnerability affects Thunderbird < 52.7, Firefox ESR < 52.7, and Firefox < 59.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- Debian Linux: 7.0, 8.0, 9.0
- Mozilla Firefox: before 59.0; before 52.7.0 — fixed in 52.7.0, 59.0
- Mozilla Thunderbird: before 52.7.0 — fixed in 52.7.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.4
- RedHat Enterprise Linux Server Eus: 7.4, 7.5
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 52.7.0, 59.0; Mozilla Thunderbird 52.7.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103388
- http://www.securitytracker.com/id/1040514
- https://access.redhat.com/errata/RHSA-2018:0526
- https://access.redhat.com/errata/RHSA-2018:0527
- https://access.redhat.com/errata/RHSA-2018:0647
- https://access.redhat.com/errata/RHSA-2018:0648
- https://bugzilla.mozilla.org/show_bug.cgi?id=1428947
- https://lists.debian.org/debian-lts-announce/2018/03/msg00010.html
- https://lists.debian.org/debian-lts-announce/2018/03/msg00029.html
- https://security.gentoo.org/glsa/201810-01
- https://security.gentoo.org/glsa/201811-13
- https://usn.ubuntu.com/3545-1/
Get alerted when CVE-2018-5129 or the next vulnerability affects your stack