What’s Vulnerable › Vulnerabilities
CVE-2018-5132
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-11 · updated 2026-06-17
- Weakness: CWE-200
Description
The Find API for WebExtensions can search some privileged pages, such as "about:debugging", if these pages are open in a tab. This could allow a malicious WebExtension to search for otherwise protected data if a user has it open. This vulnerability affects Firefox < 59.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- Mozilla Firefox: before 59.0 — fixed in 59.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 59.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103386
- http://www.securitytracker.com/id/1040514
- https://bugzilla.mozilla.org/show_bug.cgi?id=1408194
- https://usn.ubuntu.com/3596-1/
- https://www.mozilla.org/security/advisories/mfsa2018-06/
- http://www.securityfocus.com/bid/103386
- http://www.securitytracker.com/id/1040514
- https://bugzilla.mozilla.org/show_bug.cgi?id=1408194
- https://usn.ubuntu.com/3596-1/
- https://www.mozilla.org/security/advisories/mfsa2018-06/
Get alerted when CVE-2018-5132 or the next vulnerability affects your stack