What’s Vulnerable › Vulnerabilities
CVE-2018-5137
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-11 · updated 2026-06-17
- Weakness: CWE-200
Description
A legacy extension's non-contentaccessible, defined resources can be loaded by an arbitrary web page through script. This script does this by using a maliciously crafted path string to reference the resources. Note: this vulnerability does not affect WebExtensions. This vulnerability affects Firefox < 59.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- Mozilla Firefox: before 59.0 — fixed in 59.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 59.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103386
- http://www.securitytracker.com/id/1040514
- https://bugzilla.mozilla.org/show_bug.cgi?id=1432870
- https://usn.ubuntu.com/3596-1/
- https://www.mozilla.org/security/advisories/mfsa2018-06/
- http://www.securityfocus.com/bid/103386
- http://www.securitytracker.com/id/1040514
- https://bugzilla.mozilla.org/show_bug.cgi?id=1432870
- https://usn.ubuntu.com/3596-1/
- https://www.mozilla.org/security/advisories/mfsa2018-06/
Get alerted when CVE-2018-5137 or the next vulnerability affects your stack