What’s Vulnerable › Vulnerabilities
CVE-2018-5141
- Severity: high (CVSS 8.2 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-11 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in the notifications Push API where notifications can be sent through service workers by web content without direct user interaction. This could be used to open new tabs in a denial of service (DOS) attack or to display unwanted content from arbitrary URLs to users. This vulnerability affects Firefox < 59.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- Mozilla Firefox: before 59.0 — fixed in 59.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 59.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103386
- http://www.securitytracker.com/id/1040514
- https://bugzilla.mozilla.org/show_bug.cgi?id=1429093
- https://usn.ubuntu.com/3596-1/
- https://www.mozilla.org/security/advisories/mfsa2018-06/
- http://www.securityfocus.com/bid/103386
- http://www.securitytracker.com/id/1040514
- https://bugzilla.mozilla.org/show_bug.cgi?id=1429093
- https://usn.ubuntu.com/3596-1/
- https://www.mozilla.org/security/advisories/mfsa2018-06/
Get alerted when CVE-2018-5141 or the next vulnerability affects your stack