What’s Vulnerable › Vulnerabilities
CVE-2018-5148
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-11 · updated 2026-06-17
- Weakness: CWE-416
Description
A use-after-free vulnerability can occur in the compositor during certain graphics operations when a raw pointer is used instead of a reference counted one. This results in a potentially exploitable crash. This vulnerability affects Firefox ESR < 52.7.3 and Firefox < 59.0.2.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- Debian Linux: 7.0, 8.0, 9.0
- Mozilla Firefox: before 59.0.2; before 52.7.3 — fixed in 52.7.3, 59.0.2
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Eus: 7.5
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 52.7.3, 59.0.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103506
- http://www.securitytracker.com/id/1040574
- https://access.redhat.com/errata/RHSA-2018:1098
- https://access.redhat.com/errata/RHSA-2018:1099
- https://bugzilla.mozilla.org/show_bug.cgi?id=1440717
- https://lists.debian.org/debian-lts-announce/2018/03/msg00023.html
- https://usn.ubuntu.com/3609-1/
- https://www.debian.org/security/2018/dsa-4153
- https://www.mozilla.org/security/advisories/mfsa2018-10/
- http://www.securityfocus.com/bid/103506
- http://www.securitytracker.com/id/1040574
- https://access.redhat.com/errata/RHSA-2018:1098
Get alerted when CVE-2018-5148 or the next vulnerability affects your stack