What’s Vulnerable › Vulnerabilities
CVE-2018-5158
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-11 · updated 2026-06-17
- Weakness: CWE-94
Description
The PDF viewer does not sufficiently sanitize PostScript calculator functions, allowing malicious JavaScript to be injected through a crafted PDF file. This JavaScript can then be run with the permissions of the PDF viewer by its worker. This vulnerability affects Firefox ESR < 52.8 and Firefox < 60.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10, 18.04
- Debian Linux: 7.0, 8.0, 9.0
- Mozilla Firefox: before 52.8.0; before 60.0 — fixed in 52.8.0, 60.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.5, 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 52.8.0, 60.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104136
- http://www.securitytracker.com/id/1040896
- https://access.redhat.com/errata/RHSA-2018:1414
- https://access.redhat.com/errata/RHSA-2018:1415
- https://bugzilla.mozilla.org/show_bug.cgi?id=1452075
- https://lists.debian.org/debian-lts-announce/2018/05/msg00007.html
- https://security.gentoo.org/glsa/201810-01
- https://usn.ubuntu.com/3645-1/
- https://www.debian.org/security/2018/dsa-4199
- https://www.mozilla.org/security/advisories/mfsa2018-11/
- https://www.mozilla.org/security/advisories/mfsa2018-12/
- http://www.securityfocus.com/bid/104136
Get alerted when CVE-2018-5158 or the next vulnerability affects your stack