What’s Vulnerable › Vulnerabilities
CVE-2018-5164
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-11 · updated 2026-06-17
- Weakness: CWE-79
Description
Content Security Policy (CSP) is not applied correctly to all parts of multipart content sent with the "multipart/x-mixed-replace" MIME type. This could allow for script to run where CSP should block it, allowing for cross-site scripting (XSS) and other attacks. This vulnerability affects Firefox < 60.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10, 18.04
- Mozilla Firefox: before 60.0 — fixed in 60.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 60.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104139
- http://www.securitytracker.com/id/1040896
- https://bugzilla.mozilla.org/show_bug.cgi?id=1416045
- https://usn.ubuntu.com/3645-1/
- https://www.mozilla.org/security/advisories/mfsa2018-11/
- http://www.securityfocus.com/bid/104139
- http://www.securitytracker.com/id/1040896
- https://bugzilla.mozilla.org/show_bug.cgi?id=1416045
- https://usn.ubuntu.com/3645-1/
- https://www.mozilla.org/security/advisories/mfsa2018-11/
Get alerted when CVE-2018-5164 or the next vulnerability affects your stack