What’s Vulnerable › Vulnerabilities
CVE-2018-5178
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-11 · updated 2026-06-17
- Weakness: CWE-119
Description
A buffer overflow was found during UTF8 to Unicode string conversion within JavaScript with extremely large amounts of data. This vulnerability requires the use of a malicious or vulnerable legacy extension in order to occur. This vulnerability affects Thunderbird ESR < 52.8, Thunderbird < 52.8, and Firefox ESR < 52.8.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10, 18.04
- Debian Linux: 7.0, 8.0, 9.0
- Mozilla Firefox: before 52.8.0 — fixed in 52.8.0
- Mozilla Thunderbird: before 52.8.0 — fixed in 52.8.0
- Mozilla Thunderbird ESR: before 52.8.0 — fixed in 52.8.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.5, 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 52.8.0; Mozilla Thunderbird 52.8.0; Mozilla Thunderbird ESR 52.8.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104138
- http://www.securitytracker.com/id/1040898
- https://access.redhat.com/errata/RHSA-2018:1414
- https://access.redhat.com/errata/RHSA-2018:1415
- https://access.redhat.com/errata/RHSA-2018:1725
- https://access.redhat.com/errata/RHSA-2018:1726
- https://bugzilla.mozilla.org/show_bug.cgi?id=1443891
- https://lists.debian.org/debian-lts-announce/2018/05/msg00007.html
- https://lists.debian.org/debian-lts-announce/2018/05/msg00013.html
- https://security.gentoo.org/glsa/201810-01
- https://security.gentoo.org/glsa/201811-13
- https://usn.ubuntu.com/3660-1/
Get alerted when CVE-2018-5178 or the next vulnerability affects your stack