What’s Vulnerable › Vulnerabilities
CVE-2018-5188
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-18 · updated 2026-06-17
- Weakness: CWE-119
Description
Memory safety bugs present in Firefox 60, Firefox ESR 60, and Firefox ESR 52.8. Some of these bugs showed evidence of memory corruption and we presume that with enough effort that some of these could be exploited to run arbitrary code. This vulnerability affects Thunderbird < 60, Thunderbird < 52.9, Firefox ESR < 60.1, Firefox ESR < 52.9, and Firefox < 61.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10, 18.04
- Debian Linux: 8.0, 9.0
- Mozilla Firefox: before 61.0; from 53.0 before 60.1.0 — fixed in 60.1.0, 61.0
- Mozilla Firefox ESR: before 52.9 — fixed in 52.9
- Mozilla Thunderbird: before 52.9 — fixed in 52.9
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.5, 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 60.1.0, 61.0; Mozilla Firefox ESR 52.9; Mozilla Thunderbird 52.9. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104555
- https://access.redhat.com/errata/RHSA-2018:2112
- https://access.redhat.com/errata/RHSA-2018:2113
- https://access.redhat.com/errata/RHSA-2018:2251
- https://access.redhat.com/errata/RHSA-2018:2252
- https://bugzilla.mozilla.org/buglist.cgi?bug_id=1456189%2C1456975%2C1465898%2C1392739%2C1451297%2C1464063%2C1437842%2C1442722%2C1452576%2C1450688%2C1458264%2C1458270%2C1465108%2C1464829%2C1464079%2C1463494%2C1458048
- https://lists.debian.org/debian-lts-announce/2018/06/msg00014.html
- https://lists.debian.org/debian-lts-announce/2018/07/msg00013.html
- https://security.gentoo.org/glsa/201810-01
- https://security.gentoo.org/glsa/201811-13
- https://usn.ubuntu.com/3705-1/
- https://usn.ubuntu.com/3714-1/
Get alerted when CVE-2018-5188 or the next vulnerability affects your stack