What’s Vulnerable › Vulnerabilities
CVE-2018-5205
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-06 · updated 2026-06-17
- Weakness: CWE-134
Description
When using incomplete escape codes, Irssi before 1.0.6 may access data beyond the end of the string.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.04, 17.10
- Debian Linux: 9.0
- Irssi: before 1.0.6 — fixed in 1.0.6
How to fix
Upgrade to a fixed version: Irssi 1.0.6. Check the vendor advisory for mitigations.
References
- https://irssi.org/security/irssi_sa_2018_01.txt
- https://usn.ubuntu.com/3527-1/
- https://www.debian.org/security/2018/dsa-4162
- https://irssi.org/security/irssi_sa_2018_01.txt
- https://usn.ubuntu.com/3527-1/
- https://www.debian.org/security/2018/dsa-4162
Get alerted when CVE-2018-5205 or the next vulnerability affects your stack