What’s Vulnerable › Vulnerabilities
CVE-2018-5208
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-06 · updated 2026-06-17
- Weakness: CWE-119
Description
In Irssi before 1.0.6, a calculation error in the completion code could cause a heap buffer overflow when completing certain strings.
Affected products
- Debian Linux: 9.0
- Irssi: before 1.0.6 — fixed in 1.0.6
How to fix
Upgrade to a fixed version: Irssi 1.0.6. Check the vendor advisory for mitigations.
References
- https://irssi.org/security/irssi_sa_2018_01.txt
- https://www.debian.org/security/2018/dsa-4162
- https://irssi.org/security/irssi_sa_2018_01.txt
- https://www.debian.org/security/2018/dsa-4162
Get alerted when CVE-2018-5208 or the next vulnerability affects your stack