What’s Vulnerable › Vulnerabilities
CVE-2018-5223
- Severity: high (CVSS 7.2 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-29 · updated 2026-06-17
- Weakness: CWE-20
Description
Fisheye and Crucible did not correctly check if a configured Mercurial repository URI contained values that the Windows operating system may consider argument parameters. An attacker who has permission to add a repository in Fisheye or Crucible can execute code of their choice on systems that run a vulnerable version of Fisheye or Crucible on the Windows operating system. All versions of Fisheye and Crucible before 4.4.6 (the fixed version for 4.4.x) and from 4.5.0 before 4.5.3 (the fixed version for 4.5.x) are affected by this vulnerability.
Affected products
- Atlassian Crucible: from 4.4.0 before 4.4.6; from 4.5.0 before 4.5.3 — fixed in 4.4.6, 4.5.3
- Atlassian Fisheye: from 4.4.0 before 4.4.6; from 4.5.0 before 4.5.3 — fixed in 4.4.6, 4.5.3
How to fix
Upgrade to a fixed version: Atlassian Crucible 4.4.6, 4.5.3; Atlassian Fisheye 4.4.6, 4.5.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103665
- https://confluence.atlassian.com/x/Zi5sO
- https://confluence.atlassian.com/x/aS5sO
- https://jira.atlassian.com/browse/CRUC-8181
- https://jira.atlassian.com/browse/FE-7014
- http://www.securityfocus.com/bid/103665
- https://confluence.atlassian.com/x/Zi5sO
- https://confluence.atlassian.com/x/aS5sO
- https://jira.atlassian.com/browse/CRUC-8181
- https://jira.atlassian.com/browse/FE-7014
Get alerted when CVE-2018-5223 or the next vulnerability affects your stack