What’s Vulnerable › Vulnerabilities
CVE-2018-5224
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-29 · updated 2026-06-17
- Weakness: CWE-20
Description
Bamboo did not correctly check if a configured Mercurial repository URI contained values that the Windows operating system may consider argument parameters. An attacker who has permission to create a repository in Bamboo, edit an existing plan in Bamboo that has a non-linked Mercurial repository, or create a plan in Bamboo either globally or in a project using Bamboo Specs can can execute code of their choice on systems that run a vulnerable version of Bamboo on the Windows operating system. All versions of Bamboo starting with 2.7.0 before 6.3.3 (the fixed version for 6.3.x) and from version 6.4.0 before 6.4.1 (the fixed version for 6.4.x) running on the Windows operating system are affected by this vulnerability.
Affected products
- Atlassian Bamboo: from 2.7.0 before 6.3.3; from 6.4.0 before 6.4.1 — fixed in 6.3.3, 6.4.1
How to fix
Upgrade to a fixed version: Atlassian Bamboo 6.3.3, 6.4.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103653
- https://confluence.atlassian.com/x/PS9sO
- https://jira.atlassian.com/browse/BAM-19743
- http://www.securityfocus.com/bid/103653
- https://confluence.atlassian.com/x/PS9sO
- https://jira.atlassian.com/browse/BAM-19743
Get alerted when CVE-2018-5224 or the next vulnerability affects your stack