What’s Vulnerable › Vulnerabilities
CVE-2018-5229
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The NotificationRepresentationFactoryImpl class in Atlassian Universal Plugin Manager before version 2.22.9 allows remote attackers to inject arbitrary HTML or JavaScript via a cross site scripting (XSS) vulnerability in the name of user submitted add-on names.
Affected products
- Atlassian Universal Plugin Manager: before 2.22.9 — fixed in 2.22.9
How to fix
Upgrade to a fixed version: Atlassian Universal Plugin Manager 2.22.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-5229 or the next vulnerability affects your stack